Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - RMS

Pages: 1 [2] 3 4 ... 6
16
General Discussion / Re: How can I texture a model?
« on: November 27, 2008, 10:11:47 AM »
I think texturing was disabled in B2. Have you tried B5?

17
Wish List / Re: Mirror tool
« on: November 17, 2008, 11:41:34 PM »
I just uploaded B5, now with mirroring. More info here.

I have also tweaked the curve smoothing a bit, so it should give smoother results, especially if you apply a smoothing operation after you draw (just circle the area you want to smooth a few times).

18
Announcements / ShapeShop B5
« on: November 17, 2008, 11:38:26 PM »
...is up! Now with mirroring, COLLADA and STL export, a hollowing operator, and less bugs! Read more.

19
General Discussion / Re: Will there be further releases?
« on: November 17, 2008, 11:36:51 PM »
Done! Actually I uploaded the new installer on Sunday, but forgot to update the download page...

Get it here.

20
General Discussion / Re: Will there be further releases?
« on: November 13, 2008, 04:44:42 PM »
I am just working on a tutorial video for the mirroring tool, and working out a few bugs in the process. I am hoping to finish this over the weekend, and even if I don't, I think I will probably put up B5 anyway =).

21
Bugs / Re: Can't get it to run...
« on: November 03, 2008, 04:03:35 PM »
Yup, ok, that's it. I had the exact same bug show up on my GX2 when I updated to the latest drivers. NVidia introduced a bizarre OpenGL bug, I can't imagine how it happened.

I will put the current dev build up somewhere for you to download and try (I'll give you the location via e-mail)

22
Bugs / Re: Can't get it to run...
« on: November 03, 2008, 02:49:32 PM »
I can't see any screen grabs...  can you e-mail them to shapeshop@gmail.com?

(I have a feeling that I ran into this bug the other day and fixed it, but I need to see the screens to be sure. If so, I will get you to test the fix, if you don't mind)

cheers,
-RMS

23
Bugs / Re: Can't get it to run...
« on: November 03, 2008, 10:23:28 AM »
Is it completely black? Or can you see a few things at the top?

Also, what kind of processor and graphics card do you have, and if it is NVidia, have you installed the latest drivers?

24
Gallery / Re: shapeshopped rabbits--"about Us"
« on: October 28, 2008, 07:06:09 PM »
Fantastic! It is very nice. I like the tails =)

25
Wish List / Re: Mirror tool
« on: October 27, 2008, 04:43:30 PM »
Well, lucky for you, because I found some time to implement a mirror operator =). It was pretty easy to implement, and actually is pretty bad-ass. Since ShapeShop is volumetric, mirroring works in any direction, and it is even possible to use multiple mirror planes to make kaleidescope-like patterns. I am just working on a bit of extra functionality that will make it possible to smooth across the mirror plane (to get rid of sharp creases, in case the tangents aren't perfectly continuous).

I also added COLLADA and STL exporting, and an operator that automatically hollows the surface, so you can print your models at Shapeways.com (!).

And, I've fixed some bugs, in particular stroke drawing now works properly with integrated Intel GPUs (this is what most Tablet PCs have - I got a Lenovo x61t a month ago and it was driving me crazy that it was broken...)

I really need to get back to my research, so (knock on wood) I will probably push out B5 in the next week or two.

26
Wish List / Re: Mirror tool
« on: October 02, 2008, 11:41:36 PM »
I would like to spend some time adding features and then release a new version. But my wife just had a baby, so I hardly have any free time, and what time I do have, I have to spend working on my papers for SIGGRAPH. So, unfortunately, I wouldn't expect to see a new version until January =\

27
Bugs / Re: could not load my saved files
« on: August 07, 2008, 08:45:54 PM »
You could load the files that didn't open on the other computer? Or you could load new files?

Anyway, I did reproduce your problem with that file on my machine here. It was a bizarre bug though, I can't see how my save-and-load would ever have worked with that bug (!). Looks like it might have been dependent on un-initialized memory though, which would give possibly unpredictable behavior on many computers.

I have uploaded the fixed version, but I did not rename it - it is still ShapeShop B4. So, just un-install re-download, and re-install, and your problem should be fixed.

(If it is not, please let me know).

Cheers, and thanks!
-RMS

28
Bugs / Re: could not load my saved files
« on: August 06, 2008, 12:15:19 PM »
That is very strange - I have no problems opening my saved xml files.

Can you try to make a file that you can't re-open, and send it to me at rms@unknownroad.com? Then I can debug the problem and fix it. (I can't do anything about it until I have a save file that re-creates the problem).

cheers,
-RMS

29
Bugs / Re: could not load my saved files
« on: July 27, 2008, 05:07:27 PM »
I would need a copy of the file to try and debug the loading failure. I can probably recover it, though. If you want me to try, send it to rms@unknownroad.com

cheers (and the sculpture is great, of course!)
-RMS

30
Gallery / Re: An introduction (with an image)
« on: July 19, 2008, 01:02:35 PM »
fantastic!

Can you explain how you do the painting? I haven't really used modo. Do you need to generate UV coordinates for the mesh before you do the painting?

cheers,
-RMS

Pages: 1 [2] 3 4 ... 6